Pay.gov Outage

Incident Report for RCRAInfo

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 20:52 EDT

Investigating

Pay.gov website and services are currently experiencing an unexpected outage, beginning at approximately 4:00 PM Eastern. Pay.gov teams are actively engaged in finding a resolution. Please refrain from paying invoices in RCRAInfo until pay.gov services are restored.
Posted Apr 25, 2025 - 18:16 EDT
This incident affected: Third Party Services (e-Manifest Payment Widget).