e-Manifest API Validation Reminder Empty Strings in Non-Required Address Fields

Incident Report for RCRAInfo

Resolved

This incident has been resolved.
Posted May 01, 2026 - 23:40 EDT

Update

We are continuing to investigate this issue.
Posted May 01, 2026 - 16:02 EDT

Investigating

Who is affected: Industry users and systems submitting manifests via the e-Manifest API only. Users submitting manifests directly through the RCRAInfo web interface are not affected.

Issue: The e-Manifest API is currently experiencing an issue when submissions include empty strings (e.g., "") in non-required address fields, such as Street Number or Address Line 2. This may cause submission errors or unexpected behavior.

Workaround: If your system sends empty strings in non-required fields, omit those fields entirely from your API submission rather than passing an empty value. This will resolve the issue while a permanent fix is being developed.

We are actively working with the development team to resolve this. We will provide an update when a fix has been deployed.
Posted May 01, 2026 - 15:25 EDT
This incident affected: RCRAInfo Industry Application (REST API (e-Manifest web services)).